Bug: First letter typed is auto capitalized


#1

In FT 2.0, when inserting the cursor into a file and starting to type, the first letter in automatically capitalized. For instance if I position the cursor in an existing document and type “test”, it will appear as “Test”. If I insert a character in a word, and type, say adding “ed” after “test”, it will appear as “testEd”. This is unwanted behavior - how can it be fixed or avoided? It renders FT unusable (I can’t keep typing “ttest” and then going back and deleting the leading “T” in what now appears as “Ttest”.)


#2

I’m not sure, but I think this may be due to something in your account. I’m not seeing this behavior and haven’t had it reported before.

Few things to try:

  1. If you install FoldingText in your guest user account do you see the problem.

  2. If not then can you think of any typing extensions or things like that that might be causing the problem?


#3

First thanks for the quick response, it helped me think through this a bit. I have boiled it down to a conflict with TextExpander. I don’t know how to fix it yet, but will continue to investigate.


#4

In your properties, there is an option to auto capitalize. Just turn it off. I had that at first and it messed me up. It’s in Preferences->Options->Capitalize new sentences. Just uncheck it.


#5

Thanks! That took care of it. I appreciate the help.


#6

Thanks. I had the same problem and this resolved it for me. I appreciate having the community forums available.


#7

I had the same issue. The fix suggested above worked for me too. Appreciate the help.


#8

Same. Interestingly, The Edit menu would highlight as the capitalisation occurred. This made me think it had something to do with FT.


#9

That is because TextExpander uses the programs Paste hotkey to paste the expanded text (or in this case, corrected text) in to the program.