Bottom-padding and typewriter broken after 3.8


I have been loving Taskpaper with a modified version of the Notes First stylesheet to keep track of meeting notes. I believe since the 3.8 update, the ‘bottom-padding-percent’, ‘top-padding-percent’, and ‘typewriter-scroll-percent’ styles don’t affect the display any more. I added the styles into the default ‘Light’ theme to see if it was an issue with my file configuration, but I can still send the file if anyone’s interested. Does anyone else have this issue?

I’ve tried troubleshooting, but am still not able to figure this out. Is this broken for anyone else?

Same here! Really missing typewriter scrolling :frowning:

I’m trying to finish up some stuff on my WriteRoom 4 work, then I’ll get back to this and see if I can figure out what’s going on.


Just to say, I am seeing the same issue when trying to use both:

top-padding-percent and bottom-padding-percent in a custom stylesheet.

Everything else works as per the documentation, but not the padding.

This is fixed in next release. I’ll be posting preview of that release today or tomorrow.

1 Like

Looking good - thanks Jesse!

1 Like

Yes! Thanks Jesse!

Question: is there a way to fade the text before and after the current sentence? (custom script/stylesheet code etc…)

Sorry this isn’t implemented for TaskPaper 3. I do expect it to be implemented in TaskPaper 4… but I have no timeframe on TaskPaper 4 right now.