Keybinding ignored


#1

I have some custom keybindings set up across my system, and usually TaskPaper plays nice with these. But for some reason, only in TaskPaper, the keybinding I have set to ⇧⌘⏎ does not work, and actually fires the system “donk” error sound.

I don’t think ⇧⌘⏎ is used for anything in TaskPaper that I can see. Am I missing something?


#2

Hum… not sure what is up. When happens if you close all TaskPaper windows, but leave TaskPaper in the foreground… ie the main menu at top of screen still shows TaskPaper. Does it work then?


#3

Hey, Jesse. It makes the same “donk” noise—but it’s a text manipulation keybinding, so there’s nothing for it to “work” on.


#4

Sorry for the late reply… but I “think” maybe it’s something local to your setup.

I can’t think of anywhere in TaskPaper’s code that I’m handling that key combo specially. Also I just tried going into system preferences and I mapped Keyboard > Shortcuts > Launchpad & Dock > Show Launchpad to the shortcut ⇧⌘⏎. It seems to work fine for me, even when in TaskPaper.

Have you tried from your guest user account?


#5

Thanks so much for testing. Sounds like it’s definitely not a TP error. I may give my guest account a try.